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Polyspace Bug Finder Product Description

Identify software defects via static analysis

Polyspace® Bug Finder™ identifies run-time errors, data flow problems,
and other defects in C and C++ embedded software. Using static
analysis, Polyspace Bug Finder analyzes software control, data flow, and
interprocedural behavior. It lets you triage and fix bugs early in the
development process.

Polyspace Bug Finder checks compliance with coding rule standards such
as MISRA C®, MISRA C++, JSF++, and custom naming conventions. It
generates reports consisting of bugs found, code-rule violations, and code
quality metrics such as cyclomatic complexity. Polyspace Bug Finder can be
used with the Eclipse™ IDE and integrated into build systems.

For automatically generated code, Polyspace results can be traced back
to Simulink® models, dSPACE® TargetLink® blocks, and IBM® Rational®
Rhapsody® diagrams.

Support for industry standards is available through IEC Certification Kit (for
IEC 61508 and ISO 26262) and DO Qualification Kit (for DO-178).

Key Features
® Detection of run-time errors, data flow problems, and other defects in C
and C++ code

¢ Fast analysis of large code bases

¢ Compliance checking for MISRA C:2004, MISRA C++:2008, JSF++, and
custom naming conventions

e (Cyclomatic complexity and other code metrics

¢ Eclipse integration

® Traceability of code verification results to Simulink models
® Access to Polyspace Code Prover™ results

® Bug detection with low false-positive results



Related Products

Related Products

In this section...

“Polyspace® Code Prover™” on page 1-3

“Polyspace Products for Ada” on page 1-3

Polyspace Code Prover

For information about Polyspace products that verify C/C++ code, see the
following:

www.mathworks.com/products/polyspace-code-prover/

Polyspace Products for Ada

For information about Polyspace products that verify Ada code, see the
following:

www.mathworks.com/products/polyspaceclientada/

www.mathworks.com/products/polyspaceserverada/


http://www.mathworks.com/products/polyspace-code-prover/
http://www.mathworks.com/products/polyspaceclientada/
http://www.mathworks.com/products/polyspaceserverada/
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Below are four different workflows for using the Polyspace Bug Finder
product. Use Bug Finder regularly to help catch bugs and coding rule
violations as you build your project.

Configuration

Setup

Coder

Modeler

Verifier

Bug Finder Workflows

Generate Code

Choose

Different

Options

Review Results

fit requirements?

ontinue

Codingj

Fix Issues

triage, review results

Review Results

triage, fix

Report Results
to Code Author
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Polyspace and the Software Development Cycle

In this section...

“Software Quality and Productivity” on page 1-5

“Best Practices for Verification Workflow” on page 1-6

Software Quality and Productivity

The goal of most software development teams is to maximize both quality and
productivity. However, when developing software, there are always three
related variables: cost, quality, and time.

Cuality

Changing the requirements for one of these variables impacts the other two.

Generally, the criticality of your application determines the balance between
these three variables — your quality model. With classical testing processes,
development teams generally try to achieve their quality model by testing
all modules in an application until each meets the required quality level.
Unfortunately, this process often ends before quality requirements are met,
because the available time or budget has been exhausted.

Polyspace analysis and verification allow a different process. Polyspace can
support both productivity improvement and quality improvement at the same
time, although there is always a balance between the aims of these activities.

To achieve maximum quality and productivity, however, you cannot simply
perform code analysis or verification at the end of the development process.
You must integrate both into your development process, in a way that
respects time and cost restrictions.

1-5
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Best Practices for Verification Workflow

Polyspace can be used throughout the software development cycle. However,
to maximize both quality and productivity, the most efficient time to use
it is early in the development cycle.

Requirements Validation Testing

Functional Design Integration Testing

Coding

POLYSPACE

Code Analysis | Code Verification

Medule Testing

Polyspace® Verification in the Development Cycle

Typically, verification is conducted in two stages. First, you verify code as it is
written, to check coding rules and quickly identify any obvious defects. Once
the code is stable, you verify it again before module/unit testing, with more
stringent verification and review criteria.

Using verification early in the development cycle improves both quality and
productivity, because it allows you to find and manage defects soon after the
code is written. This saves time because each user is familiar with their own
code, and can quickly determine why the code contains defects. In addition,
defects are cheaper to fix at this stage, since they can be addressed before the
code is integrated into a larger system.
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¢ “Find Defects from the Polyspace Environment” on page 2-2
¢ “Find Defects from Simulink” on page 2-11
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Find Defects from the Polyspace Environment

In this section...

“Introduction” on page 2-2

“Set Up Project” on page 2-2

“Configure Text Editor” on page 2-5

“Configure Coding Rules and Run Analysis” on page 2-6
“Review Results” on page 2-6

“Fix Defects and Rerun Analysis” on page 2-10

Introduction

In this tutorial, you analyze a simple code example using Polyspace Bug
Finder. To do this analysis, the tutorial follows a common workflow for using

Polyspace Bug Finder:

1 Set up project and configuration options.
2 Run analysis.

3 Review results.

4 Fix defects and rerun analysis.

Set Up Project
Set up the source files and create a new Polyspace project to analyze these
files.

Note In this example, MATLAB_ROOT refers to the installation location of
MATLAB®. For example:

C:\Program Files\MATLAB\R2013b.

1 In a writable folder, create a new folder called bf_project.
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2 Copy the folder,
MATLAB_ROOT\polyspace\examples\cxx\Bug_Finder_Example\sources,
to the bf_project folder that you created in step 1.

3 Open Bug Finder. To open Bug Finder, you can use the Start menu,
desktop shortcut, or command line:

e Start Menu: All Programs > MATLAB > R2013b > Polyspace Bug
Finder R2013b

¢ Desktop shortcut: if you created shortcuts during installation, select the
Polyspace Bug Finder icon from the desktop

e DOS command-line: enter:

MATLAB_ROOT\polyspace\bin\polyspace-bug-finder

e UNIX command-line: enter:

MATLAB_ROOT/polyspace/bin/polyspace-bug-finder

4 In Polyspace Bug Finder, select File > New Project. The Project Wizard
opens to help you create a new Polyspace project.

5 In the Project Name field, enter bf_project as your project name.

6 Clear the Use default location check box. Enter the location of the
bf project folder that you created in step 1.

7 Select the Use Template check box to speed up the configuration process
by using a preconfigured template.
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—* Project - Properties @

Define project properties

Project definition and location
Project name |bf project
Version 1.0

Auther |username

[ Use defauit location
Location |C:\bf project I;|
Project language
@ C
) C++
Compilation Environment

| Use template

Back | Next || Finish || Cancel

8 Click Next.
9 Select Baseline_C, a generic template for C coding projects. Click Next.

10 Select the sources folder and click Add Source Files to add the source
files to your project.

2-4
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"% Project - Add Source Files and Include Folders =3
Add source files and include folders
Lookiin: sources ~| & %l £ 7
T =~ bf_project [€]
.;} 3 dynamicmemory| -1 Source
Recent Items i B2-[3 sources
] dataflow.c
|| 3 programming (€] dynamicmemory.c
Desktop 3 staticmemory = [€] umeric.c
€] other.c
B +-|€] programming.c
L ) L. [€] staticmemory.c
My Documents e
-
(.
Computer
- - . P e PN - =
(L.. Flename: | ¢ numeric.c” “other.c” sprogramming.c” “staticmemary.c 1 Add Source Fiies
Network Files of type: '(‘.:) files only - s Add Include Folders
Add recursively
[ Back ] Next [ Finish ][ Cancel ]

11 Click Finish.

Configure Text Editor

Before you start an analysis, configure your text editors through the
Polyspace Preferences dialog box. You can then view source files directly

from the Polyspace user interface.

1 Select Options > Preferences.

2 In the Preferences dialog box, select the Editors tab.

i

%' Polyspace Preferences

| Server Configuration | Project and Results Folder | Edibars§| Tools Menu | Review Statuses | Miscellaneous | Character Encoding|

-

Text editor configuration
Specify the full path to a text editor or use the browse button.
Text editor:
Specify the command line arguments for the text editor.

Arguments: Notepad++ w | |-nSLINE SFILE

C:'Program Files (x86)\Notepad ++'\notepad ++.exe

G

al

n

| oot ) [Lconed |

[ ox

2-5
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3 Specify a Text Editor to use to view source files from the Project Manager
logs. For example:

C:\Program Files\Windows NT\Accessories\wordpad.exe

4 From the Arguments drop-down list, select your text editor to specify the
command line arguments for that editor.

If you are using a text editor that is not in the drop-down list, select
Custom. In the text field to the right of Custom, specify the command line
arguments for the text editor.

5 Click OK.

Configure Coding Rules and Run Analysis

During the project setup, you selected a configuration template. The template
already set most analysis options. Now, before running analysis, you specify
one additional option for checking coding rules.

1 In the Coding Rules pane of the Configuration window, select Check
MISRA C rules to add coding rules checking to your analysis.

2 From the Polyspace toolbar, select Run. You can follow the analysis in the
Progress Monitor window.

Review Results

1 After the analysis is complete, from the Project Browser, double-click
Results > bf_project.psbf.

Polyspace switches to the Result Manager perspective and displays the
analysis results.

In the Bug Finder Results Manager, you see three windows:



Find Defects from the Polyspace® Environment

" Polyspace Bug Finder

File Edit Run Review Options Window Help
BESONE 4 Lo IEE
[ @] <5 € Nocheckselcted

swd| <] QI cotvel Whoword v |

(E=8E=E 5
‘ 5] Project Manager

Results Statistics |

I

... Check File Function Classification 5 bf_project version 1.0 (08/07/2013)
§ Virite without a further read datafiow.c bug_useless... . | | Fes analysed: 6 /6 (see loq)
? Write without = further read dataflow.c bug_doublew. .. 5
1 Nondnitisized variable datafiow.c bug_notritil... Defect Distribution
1 Non-initialized painter dataflow.c bug_notinitial. .. (Totak 41)
1 Variable shadawing dataflow.c bug_variable. ..
1 Dead code dataflow.c bug_deadcod. .. Numerical
1 Painter access out of bounds dynamicmemary.c bug_outofblo...
1 Deallocation of previously deallocated ... dynamicmemary.c bug_doublefr... Dataflow
§  Non-nitialized variable dynamicmemary.c bug_notinitial...
§  Non-nitialized painter dynamicmemary.c bug_notinitial...
N Static memory
9 Use of previously freed painter dynamicmemary.c bug_usingfre...
1 Memory leak dynamicmemary.c bug_memoryl... .
- Programming
1 Memory leak dynamicmemary.c bug_arrayno...
2 Memory leak dynamicmemary.c bug_arrayno. .
1 Integer division by zero numeric.c bug_intdivisio... Dynamic memory
? Float division by zero numeric.c bug_floatdivi...
% Integer conversion overfiow numeric.c bug_intconve. .. Other
1 sign change integer conversion overflow numeric.c bug_signcha...
1 sign change integer conversion overflow numeric.c corrected_sig... 0 5 o
1 Integer conversion overflow numeric.c bug_intoverfl...
1 Integer conversion overflow numeric.c corrected_int...
% Unsigned integer conversion overfiow  numeric.c bug_unsigne.
? Dead code numeric.c o
? Invald use of standard lbrary floating. . numeric.c Top5 ""';'z;:';s")“’"’“"'s
® Arraw accace it nfhaonds ruimaric - =
4 1, ] »
R | »v
Wariable trace No check selected
8.1
20.4
14.9
16.10
0 %5 50 75 100
0%
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Window | Purpose

Name

Results | See defects found.

STy You can view the results in an ungrouped list, by file/function, or by defect
type. In any of these views, you can sort or filter the results using the column
headers. Right-click the column header to add or remove columns. You can enter
defect-specific comments and justifications using the Status and Comments columns.

Check See more details about a selected defect.

Delars The window includes a description of the defect, the offending line of code, and, if
applicable, a code sequence to help find the root cause of the defect.

Source See the defect in the source code.

By default, a separate tab appears showing global results statistics. These statistics
can provide a big picture of the defect distribution and top coding rule violations.

As you select different checks, the source files open. Results are marked in the
source code. Red underlined code with a red exclamation point in the margin
indicates a defect. A purple triangle above the code indicates a coding rule violation.
Macro expansions are labeled with a blue M, which toggles between the macro and
the executed code.

The line of code with the selected defect is highlighted in dark blue. If a code
sequence is available, those sequential lines of code are highlighted in light blue
and a box outlines their line numbers.

{

code sequence\ ez
int* pi;
collapsed macro—— if (prev == NULL} |
22 (Fisg O LIER)_{
]

expanded macro if (pi == ({void *)0)) return ((void *)0);

i

defect 124 “Til= 1z /% Defect: Writing

return pir

1

coding rule violation

v b
int* corrected notinitializedpointer (int* prev)
{

int j = 42;

int* pi;
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1 In the Results Summary window, make sure that you select the List of
Checks setting.

2 Right-click on the column headers and add the ID column to the Results
Summary window.

3 Hover your cursor over the Check column header and select the filter

button J. Clear All and select 5.2 Identifiers in an inner scope
shall not... to view only MISRA C rule 5.2 results.

4 Select the coding rule violation in the dataflow.c file. This violation of
MISRA C rule 5.2 must be fixed eventually, but can be saved for later. The
Results Summary window has a classification, a status, and a comments
columns insert annotations that you can refer to later.

5 For the selected result, change the Status to Fix.

6 In the Comments field enter, Change identifier.

7 Select File > Save to save your annotations.

8 Clear the filter from the Check column.

9 Hover your cursor over the Family column header (the column of icons)

i

and select the filter button I* .| Clear MISRA-C Warning to filter out the
coding rule violations. Click OK.

List of Chedks. -

Family |=F Check Fils
[&7] (ay construct shall ... dyr
[ (Custom. ..} maory allocation ... dyr
[¥]1 Defect s whose result... dat
2 MISRA-C Warning construct shall ... pro

mory allocation ... dyr
construct shall ... dyr
zooyramc eapmmemory allocation ... dyr

|v 20.4 Dynamic heap memory allocation ... dyr
- 14 8 An if lavnraesion) rnatrict chall — dur

The only results left are the defects.
10 Select the File column to sort by file

11 Locate the Invalid use of == operator in the programming.c file.

2-9
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As the Check Details state, the error is an incorrect use of ==. In this
example, the == in the for-loop is supposed to be an =.

12 In the next line of code, select the red bracket to highlight the Array
access out of bounds result.

This defect is an out-of-bounds array access. As the check details state, the
array index, i, exceeds the array bounds. i reaches a value of 8 because of
the incorrect equals operator from the previous line. The previous error
causes the for-loop to loop nine times instead of four.

Fix Defects and Rerun Analysis

1 Select the Invalid use of == operator defect.

2 In the Source Code window, right-click the red code and select Open
Source Code.

In a text editor, the source code file, programming.c, opens to the incorrect
line.

3 At line 45 where the invalid operator was found, change the == to =:
for (j = 5; j < 9; j++) {

4 Save programming.c.

5 In the Polyspace environment, return to the Project Manager.

6 Rerun the analysis.

7 Open the new results.

Polyspace automatically imports your previous comments into the new
results. In the Results Summary window, find the coding rule that you
annotated earlier. You can see the Fix status and comment that you
entered now imported to the new results.

2-10
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Find Defects from Simulink

In this section...

“Introduction” on page 2-11
“Create Simulink Model and Generate Code” on page 2-11

“Run Bug Finder Analysis” on page 2-13

“Review Results” on page 2-13

Introduction

In this tutorial, you analyze the generated code from a Simulink model using
Polyspace Bug Finder. To do this analysis, the tutorial follows a common
workflow for model-generated code analysis:

1 Generate code.
2 Set up Polyspace configuration options.
3 Run analysis.

4 Review results.

Create Simulink Model and Generate Code

1 Open MATLAB and open Simulink.

2 Create the model below.

2-11
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[
_., _
T
Relational Out
- Operator
In2

3 Select Code > C/C++ Code > Code Generation Options to open the

Model Configuration window.

4 Set the following options:

Pane Option Value
Code System target file |ert.tlc
L Generate code Selected
only
Solver Type Fixed-step
Solver discrete (no continuous

states)

Fixed-step size 0.1
Optimization Remove root Selected

level I/0 zero

initialization

’Use memset to
initialize floats
and doubles to 0.0

Not selected

Optimization > Sigmdine parameters
and Parameters

Selected

5 Save your model as bf_model.
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6 From the Simulink menu, select Code > C/C++ Code > Build Model
to generate code.

Run Bug Finder Analysis

1 After the model has finished building, select Code > Polyspace > Options.

2 In the Configuration Parameters window that opens, on the Polyspace
pane, set the following options.

Option Value

Product mode Bug Finder

Project configuration

Seliieys e and MISRA rule checking

Open results automatically after

. . On
verification

These options set the type of Polyspace analysis and configure the analysis
to check for bugs and MISRA C coding rule violations.

3 From the same pane, apply your changes and click Run verification to
start the Bug Finder.

You can follow the progress of the analysis in the Command Window.
Review Results

1 After the analysis has finished, the results open in the Results Manager
window of the Polyspace environment.

In the Bug Finder Results Manager, you see three windows:

2-13
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File Edit Run Review Options Window Help
BIORE 4 R0 DB 4@ s » | Q [ ase sensitvel ] hole word = | [ Restis Wanager] ~
B @| <5 @ Nocheckselected
EE Results Summary
Ungrouped - Results Statistics 4 F B
Family 1D Check File bf_model version 1.0 (03/05/2013)
i 1 Invalid use of floating point operation  bf_model.c Author:
- 2 a.10 Al dedaraﬁons and deﬁn?t:ons of... bf_model.c Defect Distributi Top 5 codi 1 iolati
- 3 8.10 All dedarations and definitions of... bf_model.c [Total: 8)
(Totak: 1) g (Totak: 8)
- 4 8.10 All dedarations and definitions of... bf_madel.c 7
- 5 8.10 All dedarations and definitions of... bf_model.c 6
- [ 8.10 All dedarations and definitions of... bf_madel.c 5
- 7 8.10 All dedarations and definitions of... bf_madel.c 4
- 8 8.10 All dedarations and definitions of... bf_model.c Pragram ;
- 9 13. 3 Floating-point expressions shall n... bf_model.c 1
0-
8.10 13.3

o
5 e | [] variable trace No check selected

0% | Project has been loaded.

Results
Summar

See defects found.

You can view the results in an ungrouped list, by file/function, or by defect
type. In any of these views, you can sort or filter the results using the column
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Window | Purpose

Name
headers. Right-click the column header to add or remove columns. You can enter
defect-specific comments and justifications using the Status and Comments columns.

Check See more details about a selected defect.

Cretirls The window includes a description of the defect, the offending line of code, and, if
applicable, a code sequence to help find the root cause of the defect.

Source See the defect in the source code.

By default, a separate tab appears showing global results statistics. These statistics
can provide a big picture of the defect distribution and top coding rule violations.

As you select different checks, the source files open. Results are marked in the
source code. Red underlined code with a red exclamation point in the margin
indicates a defect. A purple triangle above the code indicates a coding rule violation.
Macro expansions are labeled with a blue M, which toggles between the macro and
the executed code.

The line of code with the selected defect is highlighted in dark blue. If a code
sequence is available, those sequential lines of code are highlighted in light blue
and a box outlines their line numbers.

{

code sequence\ e =9z
int* pi;
collapsed macro—— if (prev == NULL) {
if fprev == NOLL) {
q

expanded macro if (pi == ({void *)0)) return ((void *]0);

defect

i
124 i o= 4z /% Defect: Writing

return pir

1

coding rule violation

v L
int* corrected notinitializedpointer(int* prew)
{

int j = 42;

int* pi;

For this simple model, Bug Finder found one defect and eight coding rule
violations.

2 Select the Invalid use of floating point operation defect.

2-15



2 Tutorials

2-16

The Source Code pane highlights the faulty generated code. If you look in
the Check Details pane, the equality operator between the two inputs is
imprecise because both input types are floating point.

3 In the source code above the defect, click Root\In1.

In the Simulink model, the associated Inl block is highlighted in blue. This
link between the model and the generated code helps you identify the parts
of your model that are causing defect.

4 Double-click the highlighted In1 block.
5 In the Signal Attributes tab, change the Data type to Int8. Select Okay.
6 Regenerate the code by selecting Code > C/C++ Code > Build Model.

7 Rerun the analysis by selecting Code > Polyspace > Verify Generated
Code for > Model.

The results open automatically in Polyspace. In the new results,
the previous defect and an associated MISRA® coding violation have
disappeared.
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Find Defects from the Eclipse Plug-In

In this section...

“Introduction” on page 2-17

“Run Analysis and Review Results” on page 2-17

Introduction

Before starting a code analysis, you must install the Polyspace Bug Finder
plug-in for Eclipse. For instructions see, “Install Polyspace Plug-In for Eclipse
IDE” on page 2-26.

In this tutorial, you analyze a simple code example using Polyspace Bug
Finder in Eclipse. A common workflow for code analysis with Polyspace Bug
Finder is:

1 Set up project and configuration options.
2 Run analysis.

3 Review results and fix defects.

4 Rerun analysis.

This tutorial follows a shortened version of this workflow.

Run Analysis and Review Results
1 After you install the plug-in, a Polyspace menu appears on the toolbar.

Select Polyspace > Show View > Show Polyspace Run view to view
the Polyspace Run window.
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= C/C++ - Eclipse
File Edit Source Refactor Mavigate Search Project [Polyspace| Run Window Help
- | el % [ v &[> startPolyspace Ctrl+R ?[
O Stop Polyspace
[ Project Explorer 52 = g ¥ Configure Praject
= <’=?>‘ = [¥| Open Results in PVE
Close Results
Show View 3
(@) Help

2 In the Polyspace Run window, select the product you want to use.

[2. Problems % Tasks & Console [ Properties ¥ Polyspace Run 53 W>dM= O

Progress Monitor | Qutput Summary | Full Log| @  Bug Finder

Code Prover

| Analysis : 0% Total
/]
00:00:00 00:00:00

Polyspace will use Bug Finder configuration options and analysis to
analyze your Eclipse project.

3 In the Eclipse Project Explorer pane, right-click a project with C or C++
files and from the context menu select Start Polyspace Bug Finder.

Note You can also right-click a single source file to only analyze that file.

As the analysis runs, you can follow the progress in the Progress Monitor
tab of the Polyspace Run window. If your code has compilation errors that
prevent analysis, they appear in the Output Summary tab.
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4 After the analysis finishes, the Results Summary window appears. As
you select different defects, the source code switches to that line number.
Details about the error appear in the Check Details window.

" Check Details 32 = 0 " Polyspace Run " Results Summary &2 [) v = 8
Variable trace dataflow.c [ bug_variableshadowing() \List of Checks R
0 5: ¥ Variable shadowing o Check ¥ File ¥ Function G Classification #f Stat
Two variables with same name 'red' but different scope. ¥ Write without a further read dataflow.c bug_useless... -
i write without a further read dataflow.c bug_doublew...
Event Scope # Non-nitialized variable dataflow.c bug_notinitial. .. E
1 Dedaration of enum constant red’ dataflow.c #  Non-nitialized pointer dataflow.c bug_notinitial. .. 1
2 Dedaration of variable "red' bug_variableshadow ¥ Variable shadowing dataflow.c bug_variable... =
i Dead code dataflow.c bug_deadcod...
i Pointer access out of bounds dynamicmemory.c bug_outofblo...
i Deallocation of previously deallocated ... dynamicmemary.c bug_doublefr...
#  Non-nitialized variable dynamicrnemory.c bug_notinitial...
i Non-initialized pointer dynamicmemory.c bug_notinitial...
i Use of previously freed pointer dynamicmemory.c bug_usingfre...
1 Integer division by zero numeric.c bug_intdivisio.. . -
] i 3 P r L

5 After fixing bugs or adding code, you can rerun the analysis from the

Results Summary window by clicking the rerun button, [) .
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Find Defects from Visual Studio

In this section...

“Introduction” on page 2-20
“Run Analysis in Visual Studio” on page 2-20

“Review Results” on page 2-24

Introduction

Before starting a code analysis, you must install the Polyspace Bug Finder
plug-in for Visual Studio®. For instructions see, “Install Polyspace Add-In for
Visual Studio” on page 2-29.

In this tutorial, you analyze a simple code example using Polyspace Bug
Finder in Visual Studio. A common workflow for code analysis with Polyspace
Bug Finder is:

1 Set up project and configuration options.
2 Run analysis.

3 Review results and fix defects.

4 Rerun analysis.

This tutorial follows a shortened version of this workflow.

Run Analysis in Visual Studio
1 After you install the plug-in, a Polyspace menu appears on the toolbar.

Select Polyspace > Display Polyspace Log to view the Polyspace Log
window.
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0 CppExample - Microsaft Visual Studio
File Edit View Project Buld Debug Team Data Polyspace Tools Test Window Help
e R ™ - e N R R Polyspace - Results Manager
=YW =2 |0&3 wl [ Polyspace - Project Manager

Spooler

CppExample.cpp

& Display Polyspace Log

(Glebal Scope)
El// CppExample.cpp : Defines the entry
1 About

Help

#include "stdafx.h"

2 In the Visual Studio Solution Explorer view, select one or more files
that you want to analyze.

3 Right-click the selection, and select Polyspace Verification.

The Easy Settings dialog box opens.
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r ™
E Easy Settings E@g

Settings

Precision (02

Verification Level [Soﬂware Safety Analysis level 2

Results folder |C:\Pch.'5paca_Resuh5

Verification Mode Settings
@ Generate main automatically (") Use existing main

Class

Class analyzer calls [unused

Class only [l

Main generator write variables [unin'rt

Main generator calls [unused

Function called before main |

Scope

C\CppExample'\CppExampleCppExample cpp +
C\CppExample'\CppBxampletstdafx.cpp

[] use Code Prover analysis

4 In the Easy Settings dialog box, you can specify the following options for
your analyses:

e Under Settings, configure the following:
= Precision — Precision of analysis (-0)
= Passes — Level of analysis (-to)

- Results folder — Location where software stores analysis results
(-results-dir)

e Under Verification Mode Settings, configure the following:
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= Generate main or Use existing — Whether Polyspace generates a
main subprogram (-main-generator) or uses an existing subprogram
(-main)

= Class — Name of class to analyze (-class-analyzer)

- Class analyzer calls — Functions called by generated main
subprogram (-class-analyzer-calls)

- Class only — Analysis of class contents only (-class-only)

- Main generator write — Type of initialization for global variables
(-main-generator-writes-variables)

= Main generator calls — Functions (not in a class) called by
generated main subprogram (-main-generator-calls)

= Function called before main — Function called before the
generated main subprogram (-function-call-before-main)

e Under Scope, you can modify the list of files and classes to analyze.

For information on how to choose your options, see “Analysis Options for
C++".

Note In the Configuration window of the Polyspace interface, you
configure options that you cannot set in the Easy Settings dialog box. See
“Customize Polyspace Options”.

If required, clear the Use Code Prover analysis check box.
Click Start to start the analysis.

Once you start the software, you can follow its progress in the Polyspace
Log view.

Compilation errors are highlighted as links. Click a link to display the file
and line that produced the error.
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US-1dl GEL VISUD] HTPHES. —1NTCIUUESL AFTUYTANT FIESWA T LADRLLY | IUPUIY S UE W ETTTIETCARALTTCIUUE Y pUIysSpd Ce_ VisUudLn
target i386

Verifying sources ...

Verifying CppExample.cpp

CACppExample\CppExample\CppExample.cpp, line 10: error: expected a ™;

H

P

CACppExample\CppExample\CppExample.cpp, line : warning: Failed compilation.
Packing compilation data

Polyspace Log
BEEE ol e-

IThe code verffication process failed

If the analysis is being carried out on a server, use the Polyspace
Spooler or Polyspace Metrics to follow the analysis progress. Select
Polyspace > Spooler, which opens the Polyspace Queue Manager
Interface dialog box.

Review Results
Select to open the Results Manager perspective of the Polyspace interface
with the last available results. If the analysis has been carried out on a

server, download the results before opening the Results Manager perspective.

For information on reviewing and understanding Polyspace Bug Finder
results, see “View Results”.
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Install Polyspace Plug-In for Simulink

The Simulink plug-in supports the four previous releases of MATLAB. For
example, the R2014a version of the Polyspace plug-in supports MATLAB
R2012a through R2014a.

By default, when you install Polyspace R2013b or later, the Simulink plug-in
1s installed and connected to MATLAB.

You can also install the Polyspace plug-in for Simulink on a previous version
of MATLAB. You can then use the latest verification software with an

older version of Embedded Coder® or TargetLink. However, if you use a
cross-version installation of Polyspace and MATLAB, local batch analyses can
only be submitted from the Polyspace environment or polyspaceBugFinder.

Note To install a newer version of Polyspace on MATLAB R2013b or later,
you must have MATLAB installed without the corresponding version of
Polyspace.

To install the Polyspace plug-in on a previous version of MATLAB:

1 Using an account with read/write privileges, open the older version of
MATLAB.

2 Change your Current Folder to
matlabroot\polyspace\toolbox\pslink\pslink. matlabroot is the
Simulink plug-in that you want to install, for example, C:\Program
Files\MATLAB\R2014a.

3 If you have a previous version of Polyspace installed, execute the
pslinksetup('uninstall') command to uninstall it. This command does
not work with MATLAB R2013b or later (see the preceding Note).

4 Execute the pslinksetup('install') command to install the new version
of Polyspace.
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Install Polyspace Plug-In for Eclipse

In this section...

“Install Polyspace Plug-In for Eclipse IDE” on page 2-26
“Uninstall Polyspace Plug-In for Eclipse IDE” on page 2-28

Install Polyspace Plug-In for Eclipse IDE

You can install the Polyspace plug-in only after you:

Install and set up Eclipse Integrated Development Environment (IDE). For
more information, see the Eclipse documentation at www.eclipse.org.

Install Java® 7. See Java documentation at www.java.com.

Uninstall any previous Polyspace plug-ins. For more information, see
“Uninstall Polyspace Plug-In for Eclipse IDE” on page 2-28.

To install the Polyspace plug-in:

1 From the Eclipse editor, select Help > Install New Software. The Install

wizard opens, displaying the Available Software page.

2 Click Add to open the Add Repository dialog box.

3 In the Name field, specify a name for your Polyspace site, for example,

Polyspace_Eclipse_PlugIn.

4 Click Local, to open the Browse for Folder dialog box.

5 Navigate to the MATLAB Install\matlab\polyspace\plugin\eclipse

folder. Then click OK.

MATLAB_Install is the installation folder for the Polyspace product, for
example:

C:\Program Files\MATLAB\R2013b

6 Click OK to close the Add Repository dialog box.

7 On the Available Software page, select Polyspace Plugin for Eclipse.



http://www.eclipse.org/
http://www.java.com

Install Polyspace Plug-n for Eclipse

= Install =

Available Software

Check the items that you wish to install,

e

Work with:  Polyspace - file:/C:/Program Files/MATLAB/R2013b/polyspace/plugin/eclipse/ Ad
Find more software by working with the "Available Software Sites” preferences.
type filter text

Name Version
» [¥] 000 Pelyspace Plugin for Eclipse

] i +
Select All Deselect All 1 item selected
Details

Show only the latest versions of available software [T] Hide items that are already installed
Group items by category What is already installed?
[] Show only software applicable to target environment

Contact all update sites during install to find required software

-

¢
i

8 Click Next.

9 On the Install Details page, click Next.

10 On the Review Licenses page, review and accept the licence agreement.

Then click Finish.

Once you install the plug-in, in the Eclipse editor, you’ll see:

¢ A Polyspace menu

e A Polyspace Run view
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= C/C++ - Eclipse
File Edit Source Refactor Mavigate Search Project Run  Window Help
£t = S N & v & [/“ Start Polyspace Ctrl+R F [
[ Stop Polyspace
[C Project Explorer 3% =0 Configure Project

Open Results in PVE

-

=&

E &

Close Results
Show View r

Help

@

Uninstall Polyspace Plug-In for Eclipse IDE

Before installing a new Polyspace plug-in, you must uninstall any previous
Polyspace plug-ins:

1 In Eclipse, select Help > About Eclipse.
2 Select Installation Details.
3 Select the Polyspace plug-in and select Uninstall.

Follow the uninstall wizard to remove the Polyspace plug-in. You must
restart Eclipse for changes to take effect.

2-28



Install Polyspace® Add-In for Visual Studio®

Install Polyspace Add-In for Visual Studio

Install Polyspace Add-In for Visual Studio

You can install the Polyspace add-in only after you:

e Install Visual Studio.

® Uninstall any previous Polyspace add-ins. For more information see
“Uninstall Polyspace Add-In for Visual Studio” on page 2-30.

To install the Polyspace add-in:

1 In the Visual Studio editor, select Tools > Options to open the Options
dialog box.

2 Select the Environment > Add-in/Macros Security pane to display the
list of Visual Studio add-in folders.

3 Select the following check boxes:
¢ Allow macros to run

e Allow Add-in components to load
4 Click Add to open the Browse For Folder dialog box.

5 Navigate to
MATLAB_Install\matlab\polyspace\plugin\msvc\VS version

® MATLAB Install is the installation folder for the Polyspace product,
for example:

C:\Program Files\MATLAB\R2013b

® VS version corresponds to the version of Visual Studio that you have
installed, for example, 2010.

6 Click OK to close the Browse for Folder dialog box.

7 To close the Options dialog box, click OK.
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You must restart Visual Studio for the changes to take effect

. After you install
the add-in, the Visual Studio editor has:

¢ A Polyspace menu

e A Polyspace Log view

00 Microsoft Visual Studio
File Edit View Debug Team Data Polyspace | Tools Test Window Help
[g J- S 3 d J % 4 ‘:\'I ] Polyspace - Results Manager

Polyspace - Project Manager

Spooler

Display Polyspace Log

Help
About

SE®Om

Uninstall Polyspace Add-In for Visual Studio

Before installing a new Polyspace add-in, you must uninstall any previous
Polyspace add-ins.

1 In the Visual Studio editor, select Tools > Options to open the Options
dialog box.

2 Select the Environment > Add-in/Macros Security pane to display the
list of Visual Studio add-in folders.

3 Select the Polyspace add-in and select Remove.
4 To close the Options dialog box, click OK.

You must restart Visual Studio for the changes to take effect.
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Find Defects from IBM Rational Rhapsody

In this section...

“Code Analysis Approach” on page 3-2

“Adding Polyspace Profile to Model” on page 3-3
“Accessing Polyspace Features” on page 3-5
“Configuring Analysis Options” on page 3-7

“Running an Analysis” on page 3-9

“Monitoring an Analysis” on page 3-11

“Viewing Polyspace Results” on page 3-11

“Locating Faulty Code in Rhapsody Model” on page 3-12

“Template Configuration Files” on page 3-14

Code Analysis Approach

In a collaborative Model-Driven Development (MDD) environment, software
run-time errors can be produced by either design issues in the model or faulty
handwritten code. You may be able to detect the flaws using code reviews
and intensive testing. However, these techniques are time-consuming and
expensive.

With Polyspace Bug Finder, you can analyze C/C++code that you generate

from your IBM Rational Rhapsody model. As a result, you can find defects

and automatically identify model flaws quickly and early during the design
process.

For information about installing and using IBM Rational Rhapsody, go to
www-01.ibm.com/software/awdtools/rhapsody/.

The approach for using Polyspace Bug Finder within the IBM Rational
Rhapsody MDD environment is:

® Integrate the Polyspace add-in with your Rhapsody project. See “Adding
Polyspace Profile to Model” on page 3-3.
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¢ [f required, specify Polyspace configuration options in the Polyspace
environment. See “Configuring Analysis Options” on page 3-7.

® Specify the include path to your operating system (environment) header
files and run an analysis. See “Running an Analysis” on page 3-9 and
“Monitoring an Analysis” on page 3-11.

® View results, analyze errors, and locate faulty code within model. See
“Viewing Polyspace Results” on page 3-11and “Locating Faulty Code in
Rhapsody Model” on page 3-12.

Adding Polyspace Profile to Model

Before you try to access Polyspace features, you must add the Polyspace
profile to your model :

1 In the Rhapsody editor, select File > Add Profile to Model. The Add
Profile to Model dialog box opens.

2 Navigate to the folder
Polyspace_Install\polyspace\plugin\rhapsody\profiles\Polyspace.

3 Select the file Polyspace.sbs. Then click Open.

Now, if you right-click a package or file, you see Polyspace features in the
context menu.
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E IBM Raticnal Rhapsody Developer for C++ - psdemos_uml_link_airbag.rpy
File Edit View Code Layout Tools Window Help

Cemsmes|es o ammx][s
[l @ ¢ @ ¢ [ComplteSysen - | DefauitConfig

GE| M NIS S S| =0 &8 HE

Entire Model View = + 7 |
El--D psdemos_uml_link_airbag
{:I Components

E|{:I Elcka Ees

Features...

Add Mew 4
- Profiles
-1 Settings Cut Ctrl+X

-2 Use Case Diagr Copy Ctrl+C
Paste Ctrl+V
Delete from Model Del
Set Stereotype 3
Change to 3
Refactor 3
Edit Type Order

Navigate 3
Unit 3
Configuration Management 4

Check
Generate
Edit Code
Roundtrip

Farmat...

Polyspace Verification
Polyspace Help

Stop Polyspace Verification
Polyspace Spocler

Edit Configuration

View Results

Polyspace Verification is also available from the Tools menu.
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Note The 64-bit version of the Polyspace product does not support the Back
to model command with the 32-bit IBM Rational Rhapsody product.

To install the 32-bit Polyspace version, from a DOS command window, run
the following command:

DVD\Installer32bits\Windows\Disk1\InstData\VM\Polyspace.exe

Accessing Polyspace Features
To access Polyspace features in the Rhapsody editor:

1 Open the model that you want to analyze. For
example, psdemos_uml link airbag.rpy in
matlabroot/polyspace/plugin/rhapsody/psdemos. Where matlabroot
1s the location of the Polyspace installation folder.

@ IBM Raticnal Rhapsody Developer for C++ - psdemos_uml_link_airbag.rpy
File Edit View Code Layout Tools Window Help

==l | & ? | | @4 G B | X

¢ ¢ [CompleieSystem ~ | DefaultCorfig

| | | e
@

Entire Model View =

; ede
+{:| Components
+{:| Packages
+{:| Profiles
+{:| Settings
+-{1 Use Case Diagrams

2 In the Entire Model View, expand the Packages node.

3 Right-click a package, for example, AirBagFiles.
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Stop Polyspace Verification
Polyspace Spocler

Edit Configuration

View Results

You see the following Polyspace functions in the context menu:
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* Polyspace Verification — Start analysis. See “Running an Analysis”
on page 3-9.

¢ Polyspace Help — Open help.

* Stop Polyspace Verification — Stop client-based analysis. See
“Running an Analysis” on page 3-9.

¢ Polyspace Spooler — Open Polyspace Queue Manager. See
“Monitoring an Analysis” on page 3-11.

e Edit Configuration — Specify analysis options. See “Configuring
Analysis Options” on page 3-7.

® View Results — View Bug Finder results. See “Viewing Polyspace
Results” on page 3-11.

Note You must add the Polyspace profile to your model before you try
to access Polyspace functions. See “Adding Polyspace Profile to Model”
on page 3-3.

Configuring Analysis Options

To specify options for your analysis:

1 In the Entire Model View, right-click a package or class, for example,
AirbagControl.
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Entire Model View ~ + ‘
BD psdemos uml link airbag
EI{:I Compeonents

E-g&] AirBagSystem

{10 Configurations
CompleteSystem
=1 Packages

EIE'_] AirBagsFiles

: ?,E\'E"Actors

*s) Dependencies

\ Events

5 Links

{1 Object Model Diagrams

ﬁ Ohbjects

5 5sgContol
"% CrashSensor
"%, SRSControl
& Types
) Use Cases
EJ---& External

2 From the context menu, select Edit Configuration. The Configuration
pane of the Polyspace environment opens.

—* Polyspace C:\Polyspace\Polyspace_Common'\PolySpace... EE
File Edit Window Help

H E |Search: - ,@ |

T T Ey-
L2
Mame Value Internal name

Analysis options

[=]-General

----- Send to Polyspace Server ] ~server

----- Add to results repository -add-to-results-repository

----- Keep all preliminary results files 0 “eep-all-files

----- Calculate code metrics = -code-metrics

[El-Report Generation 0

-Report template name Developer -report-template
-Qutput format RTF -report-output-format

- Target/Compilation
H--Compliance with standards
+--Polyspace inner settings

|- Predsion/Scaling
H--Multitasking

[ra BN NNl Kl s

3 Select options for your analysis. In particular, you must specify the
following:
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e Target operating system (-0S-target)
e Dialect (-dialect)

¢ Include Folders (-I) — Path to your operating system (environment)
header files.

4 To save your options, in the top left corner, click the disk button.

For information on how to choose your options, see “Analysis Options for C” or
“Analysis Options for C++”.

Running an Analysis

To start an analysis:

1 In the Rhapsody editor, select Tools > Polyspace Verification. The
software opens the Polyspace Verification dialog box.

~* Polyspace Verification IE'
o g L Polyspace UML Link
POLYSPACE Rhapeody-5.8.0.7 R20118)
Coda Varlicaticn Products
Results folder:  |PolyspaceResults\SRSControl_C =

Verification mode: @) Class Expert (Main)

Class to verify: | SRSControl_C -

Verify with (highlight dasses): Deselect Al

CrashSensor_C
AirbagControl_C

/| Send to Polyspace server

Note Before starting an analysis, make sure that the generated code for
the model is up to date.
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2 In the Results folder field, specify a location for your analysis results.

3 Select the Verification mode:

¢ (Class — Select a specific class from the Class to verify drop-down list.
In addition, under Verify with (highlight classes), you can select
other classes from the displayed list, for example, CrashSensor_C.

¢ Expert — The software analyzes code according to the Generate a
main (-main-generator) options that you specify.

4 If you want to run the analysis on your Polyspace server, select Send to
Polyspace server.

5 Click Run. You see analysis messages on the Log tab of the Rhapsody
editor.

Ellpun Verification

Argument 0: '"-rtebase-dir!

Argqument l: 'C:\Polvspace‘\PolyspaceForlandCPE R201lb\Verifier\bin'

Argument 2: '-3ilent’

Argqument 3: '-call-from-ide’

Argument 4: 'rhapsody’

Argument 5: '-cig’

Argument &: 'C:\Folyspace\Polyspace_ Common\PolySpaceUMLLink\psdemos‘\CompleteSystem C++.cig!’
Argqument 7: '-opticns-to-overwrite'

Argument &: 'C:‘\Polyspace‘\Polyspace_Common\PolySpaceUMLLink\psdemos'\ps_sutomatic_options.txt'

<polyspace—-cpp R2011bk PID19320 PGID19320>

Polyspace verification of psdemos_uml_link airbag project.
Starting at 06/23/2011, 18h07.

Options used with Verifier:
-polyspace-wversion=CC-2.2.0.5 (R2011b)
-from=scratch

-date=23/06/2011

\Logl.v{.' CheckModel }, Buld i Configuration Management  Ji Animation /.

If your analysis is client-based, you can stop your analysis. In the Entire
Model View, right-click, for example, a package or a class. From the context
menu, select Stop Polyspace Verification.

To stop an analysis on the Polyspace Server, use the Polyspace Queue
Manager. See “Monitoring an Analysis” on page 3-11.
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Monitoring an Analysis

If your analysis is client-based, you can observe progress on the Log tab of
the Rhapsody editor.

Z||pun Verification -
Argument 0: '-rtebase-dir’

Argument 1l: 'C:\Polyspace‘\PolyspaceForCandCPE R2011b\Verifier\bin'

Argument 2: '-silent”

Argument 3: "-call-from-ide'

Argument 4: 'rhapsody’

Argument 5: '-cig'

Rrgument &: 'C:\Polyspace‘\Polyspace_Common'PolySpaceUMLLink\psdemos\CompleteSystem C++.cig’
Argument 7: '-opticns-to-overwrite!

Argqument &: 'C:\Polyspace‘\Polyspace Common\PolySpaceUMLLink\psdemos'\ps_automatic options.txt'

<polyspace-cpp R2011b FID19320 PEID1S320>

Polyspace verification of psdemos_uml_link airbag project.
Starting at 06/23/2011, 18h07.

Options used with Verifier:

-polyspace-wersion=CC-8.2.0.5 (R2011b)

-from=scratch

-date=23/06/2011 -
\Lagl.v{' Check Model I}\'Fjuilcl f:\ Configuration Management .}\ Animation fn'r

If your analysis is running on a Polyspace Server, in the Entire Model View,
right-click, for example, a package or a class. From the context menu, select
Polyspace Spooler to display the Polyspace Queue Manager (or Spooler).
Use the Polyspace Queue Manager to manage jobs running on a Polyspace
Server.

For more information, see “Verification Management”.

Viewing Polyspace Results

To view results from the last completed analysis, in the Entire Model View,
right-click, for example, a package or a class. From the context menu, select
View Results. The Polyspace environment opens, displaying results in the
Results Manager perspective.

For more information on Bug Finder results, see “View Results”.

Declarations for C Functions Without Arguments

By default, Rhapsody generates declarations for functions without
parameters, using the form:
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void my_function()

rather than:

void my_function(void)

This can result in the following Polyspace compilation error:

Fatal error: function 'my_function' has unknown prototype.

To avoid this problem, in Rhapsody, at the project level, set the property
C_CG::Configuration: :EmptyArgumentListName to void.

Locating Faulty Code in Rhapsody Model

To identify the faulty code within your Rhapsody model using Bug Finder
analysis results:

1 In the Results Manager perspective of the Polyspace environment, navigate
to an error, for example, a non-initialized variable at line 102 of Airbag
Control_C.

2 In the Source pane, right-click the error. From the context menu, select
Back to model.
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AirbagControI.cpp| 1 B
-

91 !

9z

93 X o= ¥r

94

a5 FrE]

S B

97 T

98 woid AirbagControl C::ReadEntry(] {

==} / /8] operation ReadEntry()

100 int new_altitude;

101

10z ArmedEntry (new altitude);

103 if (new_altitude == try @ Back to model

104 { 3 . . .

e T —— 100; tz4  Print View - Source code AirbagControl.cpp

106 ) ,@ Search "true" in current source Ctrl+F

107 else ;@ Search "true" in all sources

108 { ]

109 B Fourrent data = 1000 Lo line Sil

110 1 %= Open Source File

111 Add Pre-Justification to Clipboard

11z F7#] . .

113 1 Create Duplicate Code Window -

4| [ | r

Tip For the Back to model command to work, you must have your
Rhapsody model open.

The Back to model command works best when the Polyspace check is
enclosed by the tags //#[ and [#//.

The software locates the faulty code within your Rhapsody model.
Depending on the Rhapsody configuration, the faulty code appears either
in a dialog box or in the code view.
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Primitive Operation : ReadEntry in AirbagControl - (8]

General I Description | Implementation |Arg|.|ments | Relations | Tags | Propertiesl

void ReadEntryl)

int new_altitude; -

I rmedEnt: ew altitude);
if (new_altitude == true)
{

*current_data = 100;

m

else
{
*current_data = 1000;

4 m b

Locate QK

Note The 64-bit version of the Polyspace product does not support the
Back to model command with the 32-bit IBM Rational Rhapsody product.

To install the 32-bit Polyspace version, from a DOS command window,
run the following command:

DvD\Installer32bits\Windows\Disk1\InstData\VM\Polyspace.exe

Template Configuration Files

The first time you perform an analysis, the software

copies a template, Polyspace configuration file, from
matlabroot/polyspace/plugin/rhapsody/etc/template_language.psprj
to the project folder. The template language.psprij files specify the
default option values for code analysis. The software renames the copy

to model language.psprj, where:

® model is the name of your model
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® Jlanguage is the name of the language that the model targets, that 1s C
or C++.

You can update the template .psprj file by one of the following means:

¢ Editing it through the Polyspace environment

¢ Double-clicking the file in a Windows® Explorer window

® Replacing the template file with a copy of the .psprj file from a Rhapsody
model folder

You can then share a configuration among project members and use the
configuration with other projects.
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